prss.net
当前位置:首页 >> AnDroiD开发问题,在EClipsE里面的AppCompAt_v7的... >>

AnDroiD开发问题,在EClipsE里面的AppCompAt_v7的...

在ADT20版本后,android开发提供了有向下兼容的功能,在创建工程时,最低版本选择4.0以上就不会出现appcompat_v7这个工程,再手动修改最低版本限制就好了。

v7包版本问题,请下载23.0之后的v7包导入. 可以看到你的android.support.v7.app.AppCompatActivity里面都是空的,删掉重新导入,或者自己解压包看看这个包里面有没有文件.

你这个貌似是使用了android5.0的东西,但是没有源码,导致了values21不可用,删掉就可以了

以前低于安卓项目低于4.0,会直接添加dependencies,在最新的SDK中,新建安卓项目,如果低于安卓4.0(api14)的话,会自动添加appcompat v7包,但也许你写着项目的时候,发现自己不是想建低于4.0的项目,而又不想重新建项目,那么我们该怎么去除...

/sdk/extras/android/support/v7 这个路径下有一个appcompat项目将他引入你的eclipse,如果eclipse有就不用引入了。 选择你的项目右键Properties-Android-Add 选择appcompat_v7。 看看你的项目libs里面是否存在android-support-v4.jar,如果存在...

改成

有如下两种方法可以在Android studio中导入appcompat-v7。方法1:在项目的build.gradle文件里,用传统的自动依赖处理方式: compile ‘com.Android.support:appcompat-v7:+’,然后rebuild就可以了。 方法2: 1、直接在Module上右键Open Module Se...

点击你的工程右键--》Properties-->Android1、查看你引用的appcompat_v7包是否引用正确2、用较高的api试试Apply之后对项目Clean一下就Ok了

哎,这个问题是因为你在建立工程时,最低版本低于4.0导致的,新建工程时把版本最低设置到4.0以上 就不会出现appcompat_v7这个兼容库了,至于怎么兼容4,.0以下的,我正是在解决这个问题的过程中搜到了你这个问题。。。等我解决了再给你回复答案吧

创建4.0以上版本将不会出现。 如果我的回答没能帮助您,请继续追问。 你的采纳是我前进的动力。记得好评和采纳。

网站首页 | 网站地图
All rights reserved Powered by www.prss.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com